User Tools

Site Tools


irisware_-_browsers

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
irisware_-_browsers [2019/01/28 21:40]
raion
irisware_-_browsers [2019/01/28 22:14] (current)
raion
Line 1: Line 1:
-====irisware - Browsers====+=====irisware - Browsers=====
 This page is designed to discuss the browser situation for irisware, the currently maintained and developed IRIX package system and developmental platform. This page is designed to discuss the browser situation for irisware, the currently maintained and developed IRIX package system and developmental platform.
  
-==Current Recommended Options==+====Current Recommended Options====
 **irisware**:​ **irisware**:​
 Dillo 3 - Currently works on IRIX as of 2018. It's a basic HTML4-ish browser without JS and with basic CSS support. Its the best for IRIX in terms of speed and usability and stability. Last release was in 2015. Project appears dormant. Dillo 3 - Currently works on IRIX as of 2018. It's a basic HTML4-ish browser without JS and with basic CSS support. Its the best for IRIX in terms of speed and usability and stability. Last release was in 2015. Project appears dormant.
Line 9: Line 9:
 Firefox 2 and 3.0.19, Dillo 2 and Dillo 3. Firefox 2 and 3 are useless for modern web browsing, and GTK2 in them makes them slow, and induces various random crashes, bugs and graphical glitches. Firefox 2 and 3.0.19, Dillo 2 and Dillo 3. Firefox 2 and 3 are useless for modern web browsing, and GTK2 in them makes them slow, and induces various random crashes, bugs and graphical glitches.
  
-==Roadblocks For Better Options== +====Roadblocks For Better Options====
   ***Firefox**   ***Firefox**
 To build a version of Firefox later than 3.0.19, we need a later GTK than 2.12.12. Later versions segfault if linked against a program. Firefox is a poor choice, for long term sustainability because of several factors: To build a version of Firefox later than 3.0.19, we need a later GTK than 2.12.12. Later versions segfault if linked against a program. Firefox is a poor choice, for long term sustainability because of several factors:
Line 33: Line 32:
 Requires later GTK2 Requires later GTK2
  
-==Community Proposals==+====Community Proposals====
  
   ***Raion'​s suggestion**:​   ***Raion'​s suggestion**:​
irisware_-_browsers.txt · Last modified: 2019/01/28 22:14 by raion